Evernote Replacement "Laverna" just released remoteStorage support

Check it out: https://laverna.cc/

1 Like

Wow, awesome!

By the way, it kind of crashes on me after connecting my storage. Will look into it and file bugs on their GitHub.

Are you using Chrome or something like Opera on the Blink engine? The same thing happens to me. But it works fine with Gecko-derived browsers like Firefox. I think I forgot to report that bug though so definitely report it on Github.

Nope, using FF Nightly.

Gave this a try, but didn’t see any rs support… ?

There’s a dropdown for cloud storage in the settings. Didn’t spot it at first as well.

@andthewings - I tried using the remoteStorage feature, and it asked for permissions fine, but after creating a few notes and clicking the sync button (both in the app, and in the remoteStorage widget) I still don’t see anything showing up in my remoteStorage space.

Also, I see you’re using a ‘tags’ module, I haven’t had a look at what you’ve implemented yet but was wondering if you had a look in the remotestorage-modules repository, I implemented a tags module about a year ago. If you implemented something different, maybe we could work on merging them at some point.

@silverbucket I’m actually not a developer for the Laverna app, just an enthusiastic user. But the tags module works pretty well for me. It’s one of the reasons I chose laverna over other more mature notes apps like OpenNote (maybe it does tagging, but I couldn’t figure out how).

I think the same thing is happening for me with the sync. 5apps shows that I have the app connected, but not that space is being used in the storage meter. Also, I tried hooking up Laverna to 5apps in Internet Explorer (blegh), but it didn’t sync with the notes I have stored in Firefox. I’ll go ahead and report the bug in Github if you haven’t already.

Reported errors here: https://github.com/Laverna/laverna/issues/31

@andthewings Aha, I see, thanks for the clarification - and yes I have the same behavior you describe.

Added a comment there as well. :wink:

Posted a bounty for upgraded/fixed remoteStorage support: https://www.bountysource.com/issues/27002492-update-fix-remotestorage-support

FYI: they upgraded everything incl. their module, and it should work fine now. Check it out here:


Hey, sorry I’m still getting a looped error message: https://gist.github.com/andtheWings/93c415c1345b2f7914cf

Will post on the Laverna issues page too.

Suddenly it shows an error on firebug console, and laverna shows everything BLANK (no notes):

Uncaught (in promise) transaction abort

I haven’t done anything different since yesterday (the last day it worked correctly). Today I logged in as usual, and everything is BLANK, with that error shown in the console, and repeats itself forever.

EDIT: Now it shows an OLD VERSION of SOME of my notes. OMG…

What is happening?

@kalak Sorry to hear. The Laverna repository for bug reports is located here: https://github.com/Laverna/laverna/issues/